Back to overview
Downtime

evaluate.yaelcenter.com/app, vitalme.eu, febulous-studio.com, and 1 other service are down

Sep 22 at 02:57pm CEST
Affected services
evaluate.yaelcenter.com/app
febulous-studio.com
vitalme.eu

Resolved
Sep 22 at 03:09pm CEST

evaluate.yaelcenter.com/app, vitalme.eu, and febulous-studio.com recovered.

Created
Sep 22 at 02:57pm CEST

evaluate.yaelcenter.com/app, vitalme.eu, and febulous-studio.com went down.